Help debugging lame performance on 5GHz LEDE17.01 WRT3200

Hello,

I ran some tests with LEDE/openWRT and fell in love with it. Mainly just refurbished old ADSL routers.

But due to bad wifi at my home I decided to buy an WRT3200ACM and do some serious use of LED. Installed 17.01.4 r3560-79f57e422d and then I got sever problems with the 5Ghz band.

Basically the speed is lame to say the best but I will explain later.

First a description of the scenario. The router is in the same room I'm running tests, I can use three clients, two with linux and one with windows. Coverage isn't a problem and it's not client related.

Now, my router has a trunk port and then there is a pfsense between networks. If I connect to the LEDE router with cable everything works flawless, close to the expected 1Gbit.

I'm doing "real life" tests, that's downloading and uploading files on my NAS. As told via cable speed is magnificent. Therefor I absolutely discard any network problem.

Now, this is the problem I got. 2.4Ghz doesn't work pretty well, around 30mbit on 40Mhz channels, but it's pretty crowded here so I don't expect miracles here.

The real drama is with 5Ghz. Not many interference right now LEDE shows two clients on channel 36 two on 100 and another two on 112. I thought that this was pretty neat.

Then I test any kind of transfer and i get speeds around 10Mbit (yes lower case) a bit more on uploads. Yet, network manager claims 100% reception and 434Mbit.

I'm just using just the web interface to configure the network but doesn't matter what I try results don't change much. What is worse, if I try to use a channel over 48 the network just disappears, I can't find it from any of my clients.

This behaviour is so weird that I think there might be a problem that I'm not aware of. Here is my configuration, I reset to mostly defaults bacause I found not much difference.

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
        option country 'ES'
        option htmode 'VHT80'
        option channel '36'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option network 'vlan16'
        option encryption 'psk2'
        option key '*'
        option ssid 'benjinet-USR5'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'HT40'
        option country 'ES'
        option channel 'auto'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option encryption 'psk2'
        option key '*'
        option ssid 'benjinet-USR2.4'
        option network 'vlan16'

config wifi-device 'radio2'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option country 'ES'
        option channel 'auto'
        option htmode 'HT40'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option mode 'ap'
        option network 'vlan16'
        option encryption 'psk2'
        option key '*'
        option disabled '1'
        option ssid 'benjinet-USR5'

What should I try next? I must confess that I'm pretty useless regarding wireless networks.

Thanks a lot for any suggestion.

According to the readme, "WiFi device does not use HT rates when using TKIP as the encryption cipher. If you want to have good performance, please use AES only". So, instead of option encryption 'psk2', try with option encryption 'psk-mixed+aes'.

You are right, but I guess I left that option just for some test and forgot to reset.

Changed as you told:

wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.hwmode='11a'
wireless.radio0.path='soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
wireless.radio0.country='ES'
wireless.radio0.htmode='VHT80'
wireless.radio0.channel='36'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.mode='ap'
wireless.default_radio0.network='vlan16'
wireless.default_radio0.key='*'
wireless.default_radio0.ssid='benjinet-USR5'
wireless.default_radio0.encryption='psk-mixed+aes'

And still no difference at all. It barely runs over 10Mbit.

EDIT: seems that was just one client. The others improved quite a lot, I will check deeply and tell.

Regards.

Now I have more solid results. The encryption dramatically changed things now I can get slightly over 100Mbit speeds, now is usable.

Still, are this expected results? I mean, network-manager on linux claims a 400 to 800Mbit connection with 100% signal. I know I won't get maximum speeds in the real world, but I repeat, there is only two AP in the same channel.

There is also the problem with the channel. I can only use the lowest channel anything over 48 just makes the network to disapear from sight. And again, checked from three clients windows and linux.

Hi I have the wrt3200acm and there is a lot of problems with the older driver for the 5 GHZ driver. OpenWRT is due for a new relece in the next month or so. That relece will have the latest driver in.
Git for the driver is here:
https://github.com/kaloz/mwlwifi/commits/master
The thing with the chanel switching back to 36 is to do with DFS.
https://www.tp-link.com/us/faq-763.html
The dfs does not work as it should, but it's being worked on I have herd. How long it will take I just don't know!
The mwlwifi driver has just one dev working on it so Progress is verry slow. Btw I set my Encryption to WPA2-PSK Force CCMP AES. No mixt.

Well, then I will wait the next version and see what happens.

Now please, just to have some notions on the expected behaviour. I will leave aside 2.4Ghz because it's a crowded neighbourhood I expect a low performance.

Lets focus on the 5Ghz band. What speed should I expect in such scenario 6 nodes detected by LEDE in three channels (not much in my opinion). Excelent coverage (router is over my head more or less) and my best client is a laptop with an intel 8265 which claims a max speed of 867 Mbps.

I can get around 150Mbit. Is this all I can get? This the speed I got with a ZTE F680 and I got the WRT and LEDE thinking that the router was the problem but can't get higher speeds with this router. Also no driver problem, result is the same in windows and ubuntu.

Is this speed something to expect? It's considered a good result?

Start by getting latest mwlwifi installed.

But isn't psk+tkip+aes 'WPA only' and not WPA2?

I think it's either psk2+ccmp (aes based) or
psk2+ccmp?
I have no clue what psk2 does.
//edit
nvm psk-mixed-* is WPA/WPA 2

I would still go with psk2+ccmp or psk2+aes if only for security purposes. It may also help, as others have outlined, as 802.11n prohibits TKIP and I believe that your setting may, as result, prohibit 802.11n and 802.11ac rates.

See, for example

Edit: Confirmed that aes and ccmp have the same result, at least on "pre-release" openwrt-18.06

        case "$encryption" in
                *tkip+aes|*tkip+ccmp|*aes+tkip|*ccmp+tkip) wpa_cipher="CCMP TKIP";;
                *aes|*ccmp) wpa_cipher="CCMP";;
                *tkip) wpa_cipher="TKIP";;
        esac

Regarding encryption is seems that it's clear now.

Using the web interface I fixed encryption to:

option encryption 'psk2+ccmp'

I get these result:
I'm channel 38 (LEDE sees a single AP in this channel)

I test an Ubuntu 18.04 with an Intel 8265AC

I began the tests in the same room I have the router and then go farther. The tests are recieving and sending 1GB file from and to server. Same tests over cable gets me almost 1Gbit speeds (as expected).

Distance 1 (same room)
DL 152 Mbit
UL 264 Mbit

Distance 2
DL 144 Mbit
UL 272 Mbit

Distance 3
DL 104 Mbit
UL 208 Mbit

Distance 4
DL 32 Mbit
UL 72 Mbit

I repeated the tests with a ZTE f680 and it doesn't get any better. Also in windows is almost the same. And my other laptop is much worse (same chip but maybe the aluminum body takes its toll) but shows same behaviour.

Are these expected speeds on AC? If that's so, this is the biggest scam since the neverending story. Is there anything I should check, or just accept that it's the best I can get?

By the way, why are upload speeds so much better?

I did get on my tp link wdr3600 with ath9k 300M ac wifi and the same intel wifi chip on debian stretch ~190Mbit throughput in download direction.
Tested with iperf in tcp mode.

Did you ever tested the throughput on stock frimware?

As i know, openwrt did not support vht160 and i think your router would be capable.

Hello, thanks for your comment, it seems that the chip is a very limiting factor here.

No I didn't test the stock firmware, people comments weren't very encouraging, and I wanted a router to use specifically with LEDE.

Anyhow my tests with the ZTE show that the router makes little difference here.

Thanks anybody for your answers, it has been very interesting. I guess the conclusion is that there isn't anything I can do.

Wifi is still abit wonky with the WRT3200acm but it got better from time to time...
Imho the WRT3200acm would be the best consumer Router with a different/better wifi chip.. Not sure why Linksys/Belkin choose this marvel chip for an advertised open source Router, imho it could be a much better Router with a different wifi chip but maybe the will fix the wifi one day an also allow to adjust(lower!!) the output power for example...
Anyway it's still a very solid device and i love to use it with Davidc's build :wink: